Xcode Quick Help isn't showing up

  • A+
Category:Languages

This is the first time I have been facing this strange issue

Xcode Quick Help isn't showing up

Whenever I click on a variable, function name, etc., that is what shows up in the Quick Help section of Xcode:

Error Domain=com.apple.DNTDocumentationSupport Code=0 "disk I/O error" UserInfo={NSLocalizedDescription=disk I/O error}

I have no idea what might be causing this issue, but it seemed to have started to occur when I updated my Xcode to version 9.4.1.

On Stack Overflow, I have only found one Q&A with the same error message, but I have restarted Xcode many times, but to no avail. Does anyone know how to fix this error?

 


The main reason why this happens is usually because the Xcode documentation is missing or a new version of it is being downloaded in the background for you. For Xcode 9.4.1, you can check if the documentation has been downloaded and is in the correct place. Please do the following:

  1. Open Terminal
  2. Type cd ~/Library/Developer/Xcode/DocumentationCache/
  3. Type ls -al
  4. Find the right directory for your documentation and Xcode versions, in this case v33 and 9.4.1, respectively.
  5. Type cd v33/9.4.1/DeveloperDocumentation.index
  6. Type ls -al
  7. Find file store.db on the generated file list
  8. This database file should have the size of 17960960 bytes or roughly 18 Mb.

If you don't find this, it is because your documentation is missing and/or your connection is too slow to download this database. Thus, you need to be patient and let Xcode download it to your disk.

To quit Xcode and relaunch it usually helps, because it forces the IDE to look for the cache and update its UI.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: