Eclipse Photon – Eclipse Marketplace not launching

  • A+
Category:Languages

I just installed Eclipse Photon. I migraded one project from Oxygen to it - everything is working fine.

The problem I noticed is that I cannot open the Eclipse Marketplace. Whenever I click on it, I get the loading circle for 1-2 seconds then nothing happens.

I also tried this on a completely new empty workspace (so no old .metadata) - same behavior. I also restarted PC - didn't help.

Any ideas? Is it me only that has this problem or is it a bug due to the new version?

Thanks.

 


I managed to find the problem and fix it. I went to: Help -> About Eclipse IDE -> clicked on "Installation Details" -> tab "Configuration" -> Clicked on "View Error Log"

The default browser opened and there I noticed the following stack trace:

!ENTRY org.eclipse.ui 4 0 2018-06-28 10:38:21.036 !MESSAGE Unhandled event loop exception !STACK 0 org.eclipse.e4.core.di.InjectionException: java.lang.IllegalArgumentException: Illegal character in path at index 16: file:/C:/Eclipse Photon/eclipse/configuration/     at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65) 

It was the space character in the folder named by me: "Eclipse Photon". I renamed it to "EclipsePhoton" and the marketplace opened successfully.

Short answer: Make sure you do not have any spaces in the Eclipse installation file path.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: