Brew install on Mojave

  • A+
Category:Languages

I did these steps:

  1. Updated to Mojave
  2. Installed XCode10 beta3
  3. sudo xcode-select -switch /Applications/Xcode-beta.app/

Now I'm trying to install node8:

brew install node@8

And it gives me this error:

Error: The Command Line Tools header package must be installed on Mojave. The installer is located at: /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg

Still, doing

install -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg

does nothing, since there's no such file in my system. Where I could get it?

 


Go to /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg location and install package manually. And brew will start working.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: