All firebase libraries must be either above or below 14.0.0

  • A+
Category:Web

I have checked my app build.gradle file and these are the only lines that are related to firebase in them

/***
 * Firebase
 */
implementation 'com.google.firebase:firebase-core:15.0.0'
implementation 'com.google.firebase:firebase-messaging:15.0.0'
implementation('com.crashlytics.sdk.android:crashlytics:2.9.1@aar') {
    transitive = true
}
implementation 'com.google.firebase:firebase-ads:15.0.0'

I do not have any library that makes use of firebase so I don't think there can be an issue with a library using an older version.

The problem is I can't build gradle, clean project or rebuild project with the new v15 version of firebase as it keeps throwing the error All firebase libraries must be either above or below 14.0.0

 


Turns out I forgot to change the version number for com.google.android.gms:play-services-ads, switched it to 15.0.0 and it worked.

Here's a blog by Google that provides more information. Announcing new SDK versioning in Google Play services and Firebase

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: