Problems upgrading Ipython (prompt_toolkit incompatibilities) [on hold]

  • A+
Category:Languages

Trying to open a jupyter notebook file (.ipynb file) with this command ipython notebook filename.ipynb then I am getting Below Error while using ipython..

Traceback (most recent call last): File "c:/python/lib/runpy.py", line 193, in _run_module_as_main "__main__", mod_spec) File "c:/python/lib/runpy.py", line 85, in _run_code exec(code, run_globals) File "C:/Python/Scripts/ipython.exe/__main__.py", line 5, in <module> File "c:/python/lib/site-packages/IPython/__init__.py", line 55, in <module> from .terminal.embed import embed File "c:/python/lib/site-packages/IPython/terminal/embed.py", line 16, in  <module> from IPython.terminal.interactiveshell import TerminalInteractiveShell File "c:/python/lib/site-packages/IPython/terminal/interactiveshell.py",  line 18, in <module> from prompt_toolkit.enums import DEFAULT_BUFFER, EditingMode ModuleNotFoundError: No module named 'prompt_toolkit' 

 


Just got the same problem.

The solution for me was to pip uninstall prompt-toolkit and pip install prompt-toolkit. This uninstalled v1.0.5 and installed v2.0.4.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: