Android build miss intellij

  • A+
Category:Languages

since today I cannot build my android project because of this error :

> Could not resolve all files for configuration ':classpath'.    > Could not find intellij-core.jar (com.android.tools.external.com-intellij:intellij-core:26.0.1).      Searched in the following locations:          https://jcenter.bintray.com/com/android/tools/external/com-intellij/intellij-core/26.0.1/intellij-core-26.0.1.jar 

Android studio 3.2.1 com.android.tools.build:gradle:3.0.1

Do you have any clue ??? Thanks a lot

Vlad

 


I had the same problem with a cordova-android@7.1.1 project. I read this question Android Studio - Could not find intellij-core.jar and I solved by joining more than one answer.

Premise:

  • Android Studio 3.2.1
  • Cordova Android 7.1.1
  • Cordova Cli 8.1.2

Resolution:

File: platforms/android/build.gradle

... buildscript {     repositories {         google()         maven {             url "https://maven.google.com"         }         jcenter()     }     dependencies {          // NOTE: Do not place your application dependencies here; they belong         // in the individual module build.gradle files         classpath 'com.android.tools.build:gradle:3.0.1'     } } ... 

File: platforms/android/app/build.gradle

... buildscript {     repositories {         google()         maven {             url "https://maven.google.com"         }         jcenter()     }      dependencies {         classpath 'com.android.tools.build:gradle:3.0.1'     } }  // Allow plugins to declare Maven dependencies via build-extras.gradle. allprojects {     repositories {         google()         maven {             url "https://maven.google.com"         }         jcenter()     } } ... 

File: platforms/android/CordovaLib/build.gradle

... buildscript {     repositories {         google()         maven {             url "https://maven.google.com"         }         jcenter()     }      dependencies {         classpath 'com.android.tools.build:gradle:3.0.1'         classpath 'com.github.dcendents:android-maven-gradle-plugin:1.5'         classpath 'com.jfrog.bintray.gradle:gradle-bintray-plugin:1.7.3'     } } ... 

This solution is working to me, I hope I helped you

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: