Android project update and how to solve: “Failed to resolve: monitor”?

  • A+
Category:Languages

Because of problem that jcenter() remove some older libs I decide to update my project. So now I have:

 gradle: 4.6 

and:

classpath 'com.android.tools.build:gradle:3.2.1' classpath 'com.google.gms:google-services:3.0.0' 

I almost solve every dependency but I get

Failed to resolve: monitor 

without any clue what is that monitor ;(

 


Same for me. It works If I comment espresso libraries and:

androidTestImplementation 'com.android.support.test:runner:1.0.2' androidTestImplementation 'com.android.support.test:rules:1.0.2'

I´ve found a solution. Put google() at the beggining in

buildscript { repositories { google()

and

allprojects { repositories { google()

in project gradlew

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: