Error after Updating play-services “Program type already present: com.google.android.gms.internal.measurement.zzabo”

  • A+
Category:Languages

I updated play-services dependencies to version 15.0.0 and also added play-services-safetynet to my app.gradle. After that i always get

Program type already present: com.google.android.gms.internal.measurement.zzabo Message{kind=ERROR, text=Program type already present: com.google.android.gms.internal.measurement.zzabo, sources=[Unknown source file], tool name=Optional.of(D8)}

when building the app. here is my app.build:

apply plugin: 'com.android.application'  android {     signingConfigs {     }     compileSdkVersion 27     buildToolsVersion '27.0.3'     defaultConfig {         applicationId "XXXXXXX"         minSdkVersion 19         targetSdkVersion 27         versionCode 1         versionName "0.0.0.1"         setProperty("archivesBaseName", "XXXXXXX-$versionName")     }     buildTypes {         release {             minifyEnabled false             proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'         }     }     packagingOptions {         exclude 'META-INF/ASL2.0'         exclude 'META-INF/LICENSE'         exclude 'META-INF/license.txt'         exclude 'META-INF/NOTICE'         exclude 'META-INF/notice.txt'     }     productFlavors {     }     compileOptions {         sourceCompatibility JavaVersion.VERSION_1_7         targetCompatibility JavaVersion.VERSION_1_7     } } dependencies {     compile fileTree(include: ['*.jar'], dir: 'libs')      compile 'com.android.support:support-v4:27.1.1'     compile 'com.android.support:design:27.1.1'     compile 'com.android.support:appcompat-v7:27.1.1'     compile 'com.android.support:recyclerview-v7:27.1.1'     compile 'com.android.support.constraint:constraint-layout:1.1.0'     compile 'org.springframework.android:spring-android-rest-template:1.0.1.RELEASE'     compile 'com.fasterxml.jackson.core:jackson-databind:2.3.2'     compile 'com.koushikdutta.urlimageviewhelper:urlimageviewhelper:1.0.4'     implementation 'com.google.firebase:firebase-core:15.0.0'     implementation 'com.google.firebase:firebase-messaging:15.0.0'     implementation 'com.google.firebase:firebase-appindexing:15.0.0'     implementation 'com.google.android.gms:play-services-location:15.0.0'     implementation 'com.google.android.gms:play-services-safetynet:15.0.0'     compile 'org.kefirsf:kefirbb:1.5'     compile 'org.osmdroid:osmdroid-android:6.0.1'     testCompile 'junit:junit:4.12' } apply plugin: 'com.google.gms.google-services' 

 


You can try using the exact version number following this link:

https://firebase.google.com/support/release-notes/android#latest_sdk_versions

SDK Update - May 2, 2018 - Firebase Android SDKs now have independent version numbers, allowing for more frequent, flexible updates.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: