ValueError: exceeds max_bin_len() when attempting spacy.load()

  • A+
Category:Languages

I installed spacy using

python3 install spacy 

and downladed two English models using

python3 -m spacy download en 

and

python3 -m spacy download en_core_web_sm 

When I attempt to load any one of them with

import spacy nlp = spacy.load('en') 

I get

  File "msgpack/_unpacker.pyx", line 187, in msgpack._cmsgpack.unpackb ValueError: 1792000 exceeds max_bin_len(1048576) 

Googling didn't help me at all and I don't understand what the error is. I'd be thankful for any pointers.

 


try pip install msgpack==0.5.6

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: