Error: could not find com.google.gms:google-services:4.2.0

  • A+
Category:Languages

today I was trying to update com.google.gms:google-services to 4.2.0 from 4.1.0 as it's the latest version and recommended by firebase. But I get this error:

Could not find com.google.gms:google-services:4.2.0. Searched in the following locations:     https://jcenter.bintray.com/com/google/gms/google-services/4.2.0/google-services-4.2.0.pom     https://jcenter.bintray.com/com/google/gms/google-services/4.2.0/google-services-4.2.0.jar     https://dl.google.com/dl/android/maven2/com/google/gms/google-services/4.2.0/google-services-4.2.0.pom     https://dl.google.com/dl/android/maven2/com/google/gms/google-services/4.2.0/google-services-4.2.0.jar     https://maven.fabric.io/public/com/google/gms/google-services/4.2.0/google-services-4.2.0.pom     https://maven.fabric.io/public/com/google/gms/google-services/4.2.0/google-services-4.2.0.jar Required by:     project : 

And here is my project's build gradle:

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript {     repositories {         jcenter()         google()         maven {             url 'https://maven.fabric.io/public'         }     }     dependencies {         classpath 'com.android.tools.build:gradle:3.2.1'         classpath 'com.google.gms:google-services:4.2.0'          classpath 'com.jfrog.bintray.gradle:gradle-bintray-plugin:1.8.4'         classpath 'com.github.dcendents:android-maven-gradle-plugin:2.1'         // These docs use an open ended version so that our plugin         // can be updated quickly in response to Android tooling updates          // We recommend changing it to the latest version from our changelog:         // https://docs.fabric.io/android/changelog.html#fabric-gradle-plugin         classpath 'io.fabric.tools:gradle:1.27.0'     } }  allprojects {     repositories {         jcenter()         maven {             url 'https://maven.google.com/'         }         google()     } } 

Any ideas how to fix it? Thanks in advance.

 


Because google-services:4.2.0 is not available at Central Repository, so it needs to be downloaded from Android Tools Repository. To add this to your project add

maven { url 'https://dl.bintray.com/android/android-tools' } 

this to buildscript repositories. For more refer to https://mvnrepository.com/artifact/com.google.gms/google-services/4.2.0

buildscript {     repositories {         jcenter()         google()         maven {             url 'https://maven.fabric.io/public'         }         //  Add this to your project          maven { url 'https://dl.bintray.com/android/android-tools' }     }     dependencies {         classpath 'com.android.tools.build:gradle:3.2.1'         classpath 'com.google.gms:google-services:4.2.0'          classpath 'com.jfrog.bintray.gradle:gradle-bintray-plugin:1.8.4'         classpath 'com.github.dcendents:android-maven-gradle-plugin:2.1'         // These docs use an open ended version so that our plugin         // can be updated quickly in response to Android tooling updates          // We recommend changing it to the latest version from our changelog:         // https://docs.fabric.io/android/changelog.html#fabric-gradle-plugin         classpath 'io.fabric.tools:gradle:1.27.0'     } }  allprojects {     repositories {         jcenter()         maven {             url 'https://maven.google.com/'         }         google()     } } 

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: