Could not find any matches for com.android.tools.build:gradle:+

  • A+
Category:Languages

I'm trying to build/run an ionic project but from today this error comes up and I could not find any answer. Please, help me.

Error: Could not find any matches for com.android.tools.build:gradle:+ as no versions of com.android.tools.build:gradle are available.

Ionic Version: 4.5.0
Cordova: 6.5.0
NPM: 6.4.1
Gradle: Gradle 4.10.2

Kotlin DSL: 1.0-rc-6
Kotlin: 1.2.61
Groovy: 2.4.15
Ant: Apache Ant(TM) version 1.9.11 compiled on March 23 2018
JVM: 1.8.0_191 (Oracle Corporation 25.191-b12)
OS: Windows 7 6.1 amd64

 


On my specific case the problem was with fcm plugin, this was what I did:

  • In platforms/android/build.gradle check buildscript gradle classpath version, my case was 2.2.3 (com.android.tools.build:gradle:2.2.3)

  • Then, in platforms/android/cordova-plugin-fcm/XXXX-FCMPlugin.gradle change classpath 'com.android.tools.build:gradle:+' to the same version found above: classpath 'com.android.tools.build:gradle:2.2.3'

That's it, fixed for me.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: