updating the version of com.google.android.gms to 15.0.2

  • A+
Category:Languages

I have updated my Firebase SDK version. But theres error of updating the version of com.google.android.gms to 15.0.2. I tried to make firebase and google services of same version but it wont work.

Dependencies

dependencies { implementation 'com.google.firebase:firebase-messaging:15.0.2' implementation 'com.android.support:design:26.1.0' implementation fileTree(include: ['*.jar'], dir: 'libs') implementation 'com.google.firebase:firebase-ads:15.0.1' androidTestImplementation('com.android.support.test.espresso:espresso-core:2.2.2', {     exclude group: 'com.android.support', module: 'support-annotations' }) implementation 'com.android.support:appcompat-v7:26.1.0' implementation 'com.android.support.constraint:constraint-layout:1.1.0' implementation 'org.parceler:parceler-api:1.1.9' annotationProcessor 'org.parceler:parceler:1.1.9' implementation 'com.google.code.gson:gson:2.8.2' implementation 'com.squareup.retrofit2:retrofit:2.3.0' implementation 'com.squareup.retrofit2:converter-gson:2.3.0' implementation 'io.reactivex:rxjava:1.2.3' implementation 'io.reactivex:rxandroid:1.2.1' implementation 'com.jakewharton.rxbinding:rxbinding:1.0.0' implementation 'com.squareup.retrofit2:adapter-rxjava:2.1.0' androidTestImplementation 'com.google.code.findbugs:jsr305:3.0.1' implementation 'com.squareup.okhttp3:logging-interceptor:3.2.0' implementation 'com.jakewharton:butterknife:8.8.1' annotationProcessor 'com.jakewharton:butterknife-compiler:8.8.1' debugCompile 'com.squareup.leakcanary:leakcanary-android:1.5.4' releaseCompile 'com.squareup.leakcanary:leakcanary-android-no-op:1.5.4' implementation 'com.google.dagger:dagger-android:2.11' implementation 'com.google.dagger:dagger-android-support:2.11' // if you use the support libraries annotationProcessor 'com.google.dagger:dagger-android-processor:2.11' annotationProcessor 'com.google.dagger:dagger-compiler:2.13' implementation 'com.google.auto.value:auto-value:1.5.2' implementation 'com.jakewharton.timber:timber:4.1.2' implementation 'org.greenrobot:eventbus:3.0.0' testImplementation 'junit:junit:4.12' implementation 'com.twitter.sdk.android:twitter:3.1.1' implementation 'com.android.support:recyclerview-v7:26.1.0' implementation 'com.android.support:recyclerview-v7:26.1.0' implementation 'com.simplecityapps:recyclerview-fastscroll:1.0.16' implementation 'com.google.android.gms:play-services-location:15.0.1' implementation 'com.android.support:cardview-v7:26.1.0' implementation project(':linkedin-sdk') implementation 'com.azoft.carousellayoutmanager:carousel:1.2.1' implementation 'com.android.support:multidex:1.0.2' implementation 'gun0912.ted:tedpermission:2.1.0' implementation project(':libphonenumber-5.9') implementation 'com.facebook.android:facebook-login:4.30.0' implementation 'com.anjlab.android.iab.v3:library:1.0.44' implementation 'com.github.bumptech.glide:glide:3.8.0' implementation 'com.android.support:exifinterface:26.1.0' } 


Try Below Code:

1.build.gradle(gradle)

change :

classpath 'com.google.gms:google-services:3.2.0' 

To :

  classpath 'com.google.gms:google-services:3.2.1' 

follow below link:

https://stackoverflow.com/a/50152496/6920195

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: