Can't install numpy after a pip upgrade

  • A+
Category:Languages

For some reason, after pip is upgraded to version 19.0, I'm not able to install the most recent version of numpy (it still perfectly works with pip version 18.1).

When I run

pip install numpy --no-cache 

I get this exception

Exception: Traceback (most recent call last):   File "/home/me/.venvs/_/lib/python3.6/site-packages/pip/_internal/cli/base_command.py", line 176, in main     status = self.run(options, args)   File "/home/me/.venvs/_/lib/python3.6/site-packages/pip/_internal/commands/install.py", line 346, in run     session=session, autobuilding=True   File "/home/me/.venvs/_/lib/python3.6/site-packages/pip/_internal/wheel.py", line 848, in build     assert building_is_possible AssertionError 

I'm also using python version 3.6, and virtualenvwrapper version 16.0.0.

UPD 0

pip install numpy --no-cache -v 

gives this tremendous output

UPD 1 I've opened a bug request on the numpy issue tracker.

 


That is because pip v19.0 was released yesterday and the latest push to the numpy git rep was 10 days ago. I think we have to wait for an update to be compatible with pip v19.0.

Edit 1: Based on @frmdstryr comment, pip v19.0.1 has been released to fix this.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: