Probable version skew in pre-compiled xxx

  • A+
Category:Languages

I'm installing a package onto a virtual machine(ubuntu18.04). Here are the instructions I used:

apt-get install perl6 && /  git clone https://github.com/ugexe/zef.git && cd zef && perl6 -I. bin/zef install . && /  /usr/lib/perl6/site/bin/zef install Shell::Command && /  PYTHON_CONFIG=/usr/bin/python3-config /  /usr/lib/perl6/site/bin/zef -v install https://github.com/eatingtomatoes/Inline-Python3.git --/test --debug 

Following is the output:

.... ===> Building [OK] for Inline::Python3:ver<0.1> ===> Installing: LibraryMake:ver<1.0.0>:auth<github:retupmoca> ===> Install [OK] for LibraryMake:ver<1.0.0>:auth<github:retupmoca> ===> Installing: Inline::Python3:ver<0.1> ===> Install [FAIL] for Inline::Python3:ver<0.1>: ===SORRY!=== Probable version skew in pre-compiled  'site#sources/95D204DDA68A3E05E891AA531EBED9270C46B3F7  (Inline::Python3::InstanceConverter)' (cause: no object at index 499)  ===SORRY!=== Probable version skew in pre-compiled  'site#sources/95D204DDA68A3E05E891AA531EBED9270C46B3F7  (Inline::Python3::InstanceConverter)' (cause: no object at index 499) 

When I executed perl6 -e "use Inline::Python3; say 'hi'" in shell, it reported:

===SORRY!=== Probable version skew in pre-compiled  'site#sources/95D204DDA68A3E05E891AA531EBED9270C46B3F7  (Inline::Python3::InstanceConverter)' (cause: no object at index 499) 

The Inline::Python3 package is a perl6 package developped by myself. It runs well on my pc.

perl6 --version said:

This is Rakudo version 2018.03 built on MoarVM version 2018.03 implementing Perl 6.c. 

I don't know what the 'version skew' is. How can I fix the error?

 


Following @jjmerelo's advice, using the latest compiler provided by rakudo-pkg solved the problem.

Comment

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: