Android Plugin for Gradle 3.0.0 : Could not find com.google.http-client:google-http-client-parent:1.24.1 Languages

Android Plugin for Gradle 3.0.0 : Could not find com.google.http-client:google-http-client-parent:1.24.1

I had to migrate my android project to new version of Android Studio and Android pluging for Gradle.I followed all instructions at https://developer.android.com/studio/build/gradle-plugin-3-0-0-migration?utm_source=android-studio#new_configurations but when sync and build, i got a build error related to google-http-client-parent:1.24.1 stating it is not present in repositories Maven or Jcenter (indeed this version doesnt...
Read More